PDA

View Full Version : F A O Nanobot


data
5th May 2003, 01:05 AM
Hi Nano

getting the following message when i press the STATS button in the DF Forum

RunTime Error has occurred
do you wish to debug
Line 415
Error 'L10CL' is endefined

is this a problem your end or my end

Regards
Tom

Rids
5th May 2003, 05:09 AM
I'm getting the same one
I also get it on the Ninja front page and have done ever since reloading winXP. I think it's due to the javascript being used for the page stats. Maybe a download of the latest virtual machine from MS will cure it because loading java from sun sure didn't!

Nanobot
5th May 2003, 09:25 AM
I have corrected the team-ninja.com error, it was a bug in the code (I really should learn javascript so I can fix these things quicker) :D

I will look into the NM front page error now :)

data
5th May 2003, 09:53 AM
you are a gent Nano

Rids
5th May 2003, 01:58 PM
what was the error Doug, because I was getting it on web-pix too (I was running estats4all there too)?

Nanobot
5th May 2003, 02:55 PM
I have not sorted out the NM home page as that looks to be a java version problem. But the problem with ninja-micros.com was that the java code used the variable L10cl but was referencing it as L10CL and java varaible names are case sensitive.

Rids
5th May 2003, 09:51 PM
well the front page seems to have stopped doing it now so you either fixed it later or a magic wand was waved :lol:

Nanobot
5th May 2003, 10:25 PM
Well I could not recreate the error but the code in pphlogger.js had a /* near the beginning to indicate a comment. As far as I know comments should be // so I changed the comment header block.

Fingers crossed that that has cured it :)

Ragnarog
5th May 2003, 10:30 PM
Not getting that error anymore either :D

Rag

Nanobot
5th May 2003, 10:32 PM
Don't you just love intuitive programming :lol: